"Safety Hub" content not displaying on some lists
Incident Report for PeopleSafe
Resolved
Our Development Team have now resolved this issue affecting some customers using "Safety Hubs". Risk and Safety Plan lists should now be correctly showing content in organisations downstream of Safety Hubs.

Our apologies for any inconvenience; please contact us via help@peoplesafe.co.nz if you have any queries.
Posted almost 2 years ago. Nov 23, 2017 - 21:05 NZDT
Investigating
We are currently investigating an issue whereby customers using "Safety Hubs" to centrally manage their Risks and Safety Plans may not be seeing these on list views in their downstream organisations, via the web application. This does not appear to be affecting the mobile app.

The development team is currently investigating. Apologies for any inconvenience; we’ll update you as soon as the cause has been identified.
Posted almost 2 years ago. Nov 23, 2017 - 17:25 NZDT